Smog issue!

Engine work, Tranmissions, LSD's, Diff swaps, etc
User avatar
aznpoolpro
Stage 1
Posts: 68
Joined: Mon Oct 05, 2009 2:27 am
Car(s): 1993 Miata

Smog issue!

Postby aznpoolpro » Thu Aug 08, 2013 6:04 pm

So I went to get my smog done and It failed everything was good except the NO here was the first attempt:

15MPH-Max:726-Measured:3590 Failed
25MPH-Max:786-Measured:63 Pass

I do have a taped Intake hose (the elbow) that connects to the MAF so I thought that would be the problem. So I went to go buy a new one and put it on.
Then I tried 2 days later IT FAILED AGAIN! This time with worse numbers:

15MPH-Max:726-Measured:3337 Failed
25MPH-Max:786-Measured:3622 Failed

So I noticed my car was running hard and idling high. I already did a spark plug and spark plug wire change plus an oil change about 2 months ago.
Then my friend suggests to do seafoam in the vacuum line and the gas tank. After doing that I noticed a huge difference that it idles and drives a hell of a lot smoother.
Questions is should I still change out my O2 sensor and when I drove it for 2 years with the intake hose leak would it have affected the O2 sensor? What else should I look for? I have checked all vacuum hoses and changed my air filter as well. Don't wanna fail the 3rd one....
User avatar
Massiah
Stage 2
Posts: 416
Joined: Mon Nov 28, 2011 10:27 am
Car(s): Slow Cars
Location: San Jose

Re: Smog issue!

Postby Massiah » Thu Aug 08, 2013 7:23 pm

Image
'03 MRS, '04 S2k
speedypenguin
Stage 2
Posts: 376
Joined: Tue Aug 09, 2011 10:38 pm
Car(s): '94 Miata
Location: Berkeley/Pleasanton, CA

Re: Smog issue!

Postby speedypenguin » Thu Aug 08, 2013 11:30 pm

...were your numbers really 3000+...?
Image
Brian
User avatar
aznpoolpro
Stage 1
Posts: 68
Joined: Mon Oct 05, 2009 2:27 am
Car(s): 1993 Miata

Re: Smog issue!

Postby aznpoolpro » Thu Aug 08, 2013 11:59 pm

Yeah I know nuts....
User avatar
Massiah
Stage 2
Posts: 416
Joined: Mon Nov 28, 2011 10:27 am
Car(s): Slow Cars
Location: San Jose

Re: Smog issue!

Postby Massiah » Fri Aug 09, 2013 8:03 am

For serious - clean EGR, oil change, meow meow. A good majority of the Miatas I see fail are cat related. I would also do a pretest (like $20 or so) instead of the legit test, just in case.
'03 MRS, '04 S2k
User avatar
aznpoolpro
Stage 1
Posts: 68
Joined: Mon Oct 05, 2009 2:27 am
Car(s): 1993 Miata

Re: Smog issue!

Postby aznpoolpro » Fri Aug 09, 2013 9:55 am

Unfortunately I'm allergic to cats but the cat is new and there is no exhaust leak. There is no EGR for mine since it's a 1.6L. Oil change was done about 2-3 months ago.
angelcamron750
Stage 0
Posts: 2
Joined: Tue Sep 17, 2013 12:48 am
Car(s): BMW
Location: California
Contact:

Re: Smog issue!

Postby angelcamron750 » Tue Sep 17, 2013 12:55 am

Change oil and also check spark plugs.
User avatar
aznpoolpro
Stage 1
Posts: 68
Joined: Mon Oct 05, 2009 2:27 am
Car(s): 1993 Miata

Re: Smog issue!

Postby aznpoolpro » Mon Dec 15, 2014 1:50 pm

I know this is an old thread but I feel like just incase anyone was looking it I will update. The issue was fixed with installing a new O2 Sensor.
lissamartin043
Stage 0
Posts: 10
Joined: Wed Dec 13, 2017 9:36 pm
Car(s): car

Re: Smog issue!

Postby lissamartin043 » Thu Dec 21, 2017 2:48 am

Thanks aznpoolpro for new update.

Return to “Power and Performance”

Who is online

Users browsing this forum: No registered users and 1 guest